@Rumpelstilzchen

Тег linux в блоге Rumpelstilzchen

Rumpelstilzchen

Пользуетесь ночнушкой ФФ и ВДРУГ все сломалось и интернет адреса не вводятся в адресную строку и при вводе нету подсказок с посещенными страницами? about:newtab показывает пустые квадратики? Поиск из поисковой\адресной строки не работает?
Не волнуйте, это просто стандартное мозилловское SNAFU - Situation Normal, All Fucked Up. Наши инженеры уе рабоатют над этим (нихрена).
Выход есть - удалите русскую локаль или попробуйте в настройках Основыне - Языки удалить из списка языков русский. Перехапустите и все должно работать.
Еще можно вводить адреса с префиксами http:// и https:// - это тоже помогает, но поиск и подсказки работать не будут все равно.

Rumpelstilzchen

Чтение лога с крашем показало что клиент скорее жив чем мертв - ему понадобился еще и javafx.swing
Запустилось, нашло лампочку, но при попытке что-тос ней мделать грохнулось уже намертво.
Теперь самая снятная ошибка это ...cannot access class com.sun.javafx.collections.VetoableListDecorator (in module javafx.base) because module javafx.base does not export com.sun.javafx.collections to unnamed module @71998228

Как пишут в инторнетах - потому что код говно и древний, использует deprecated классы.

Rumpelstilzchen

Абзац иногда случается с этой Явой...
Итак, решило я поиграться со своей Yeelight\Mi Smart Bulb (каким-то раком это одно и тоже). Нашло интерсное нечно - Jeelight, приложение написанное на Жабе, можно управлять лампой. Ссылка - https://blueforcer.de/jeelightapp/
Интересно думаю, лол.
Нужна Жаба. ОК, устанавливаем default-jre - ставится Ява 11 (Запомните этот момент).
Запускаем Jeelight.jar - ничего. Ок, запускаем из консоли и...
Error: JavaFX runtime components are missing, and are required to run this application

Хмм, ок, ЖабаФак. Ставим openjfx. Запускам - тоже самое.
Гуглим. Оказывается начиная с Жабы 11 они как-то стремно отделили JFX от Жабы, поэтому надо так "java --module-path "/usr/share/openjfx/lib" --add-modules=javafx.controls,javafx.fxml"
Пробуем - валится с java.lang.NoClassDefFoundError: javafx/scene/web/WebView (WebView, святые угодники!)
Ах тыж мать его, модули надо руками подбирать. На, жри - java --module-path "/usr/share/openjfx/lib" --add-modules=javafx.controls,javafx.fxml,javafx.web
Показывает логотип и...валится
(java:13509): Gdk-WARNING **: 02:24:17.643: XSetErrorHandler() called with a GDK error trap pushed. Don't do that.

Дальше идеи кончились. ХОУЛИ ЩИТ. Пишут что походу проще поставить Java 8, хотя есть смутное ощущение что валиться будет и там. Кстати не факт что поможет, т.к. на сцайте сказано что нужен "latest Java Runtime" и ссылка ведет на JRE10

Rumpelstilzchen

А что за фигня такая с ghostscript? Обновления с заплатками безопасности валят один за другим. Решето-с?

Rumpelstilzchen

Чес слово, самая бесячая вещь в Линуксе - Bluetooth. Да, с появлением Blueman стало проще, но это поправило только проблемы гуя и общего UX, а вот под капотом все еще очень уныло.
Блюпуп рандомно перетает работать, посылаемые файлы не отправляются, принимаемые не принимаются, или приниvаются но пишутся в /dev/null. Даже сопряжение работает через раз!
С поддержкой гарнитур вообще смехопанорама - оно то работает, то валит адовым кол-вом невнятных ошибок. Тут конечно надо сказать спасибо еще и ПшшшАудио, так сказать два глюкалова сошлись в одной точке.
Казалось бы в Бубунточке пару релизов назад что-то делали чтобы оно начало работать, но результат все еще очень так себе.

Rumpelstilzchen

Вопрос, а можно в Лялихе как-то узнать что за приложение по его окну? А то у меня предустановленок акое-то говно по выбору разработчика дистрибутива, которое постоянно перехватывает файловые ассоциации на себя, а удалить его непойми как потому что ЙОБАННЫЕ надмозги переводят названия приложений на русский язык.

Rumpelstilzchen

Касательно отвала сети - вот это решение https://askubuntu.com/a/1041358/856436 помогло

Rumpelstilzchen

Вопрос Линукс-Богам. Чето у меня непруха с Убунтой 18.ХХ вообще. Сначала у меня на Нвидии Xubuntu с ума с ходил (пришлось перелезть на Mate, хотя оно мне не очень "ндравитцо"), а теперь новая беда - после суспенда отваливается проводная сеть причем нааапрочь. Настолько напрочь что рестарт Network-manager не дает ничего.
Затык - в дровах, r8169 висит в заруженных но не работает.
Нашло на Реддите такой рецепт - https://www.reddit.com/r/Ub...internet_connection/
Вкартце - засунуть в системд скрипт который после выхода из ждущего режима автоматически исполняется и выполняет modprobe -r r8169 пауза modprobe r8169.

Есть такой рецепт - еще не пробовало, https://askubuntu.com/a/1041358/856436

Наконец, если тоже не помжет можно сделать бинарник c suid который будет дергать .sh скрипт, но это уже совсем некошерно.
Если проделать эти две команды РУКАМИ из консоли - помогает, драйвер перезагружается и сеть работает. А вот автоматически силами системд - не желает.
Драйвер тот что надо, скрипт положен туда куда надо, права выставлены как надо. Нифига. Проблема толи в Системд толи в том скрипте что выложен на реддит.

Rumpelstilzchen

Nvidia-390 задолбал падениями. Обязательно, раз в примерно двое суток - паденя драйвера и весь экран в кислотных цветов кашу.
Может Nvidia-396 поможет (а если не, то есть еще 410 и 415)...

Rumpelstilzchen

Microsoft официально зохавали Obsidian (Pillars of Ethernity, Tyranny) и InXile (Bards Tale).
"Муа-ха-ха", сказали представители компании, "сегодня пингвинячии игры, завтра ядро, а потом - весь мир!".
Такие дела.

Rumpelstilzchen

"2) WebRender won't be turned on for Linux for the foreseeable future."
https://bugzilla.mozilla.or...g.cgi?id=1492580#c12

Rumpelstilzchen

Почему в Лялихе "уведомления" на рабочем столе такое ненужно? Ну вот пример - приходит уведомление от браузера, что в почту насыпалсч очередной шпам, ты стараешься тыкнуть нв крестик потому что тебе НЕ ИНТЕРЕСНО, но нет, тыкается на уведомлении и трах-тарарах вместо твоей вкладки с любимым порно анимэ открывается вкладка со спамом.
И в тоже самое время, когда приходят уведомления от Pidgin и ты тыкаешь на них чтобы ответить на мессагу НЕ ПРОИСХОДИТ НИЧЕГО, даже если ты прицельно попадешь в кнопку Show.

Rumpelstilzchen

Спустя полгода я таки выяснило что за хрень у меня с дровами Нвидии на Xubuntu 18.XX (стати обновление с 18.04 до 18.10 не помогло).
Оказалось что...XFCE на 18.XX тупо адски глючит с Нвидией версии 39Х
Пчоему - неясно, на форуме офф Нвидии разводят руками, говорят ебите Каноникал. Пришлось сменить XFCE на MATE и все заработало как надо. кстати н Nouveau все ОК работает.

Rumpelstilzchen

Fingerprint Unlock
The core fingerprint stack has landed in Cosmic with fprintd and libfprint being promoted to the main archive.  Fingerprints can be used to unlock a session which has already been logged in to, not to log you in to a new session.  This is a security consideration since fingerprints are considered to be equivalent to usernames, not passwords. As users can already chose to automatically login or opt not to have to unlock the screen with a password, fingerprints are equivalent here. Note that you will still need to have drivers for you fingerprint reader to make full use of this.

Ну собсно все как ожидалось.

Rumpelstilzchen

А почему на всяких онлайн киношках в FAQ при упоминании Linux начинается какая-то дикая пурга про Flash и HAL и что поэтому мол они Лялих не поддерживают.
Процитирую:

"В OS Linux есть возможность просматривать фильмы, но для воспроизведения защищенного контента потребуется установить модуль HAL для Adobe Flash Player.
В ОС Ubuntu, начиная с версии 10.4 модуль слоя аппаратных абстракций (HAL) по умолчанию не включен в состав дистрибутива, в связи с этим Flash Player не может воспроизвести содержимое, которое защищено с помощью DRM, при этом без проблем воспроизводя незащищенный контент (поэтому трейлеры у Вас воспроизводятся нормально).

Для того, чтобы установить модуль HAL необходимо выполнить следующие действия:

открыть программу «Терминал»
ввести в строку терминала команду sudo apt-get install hal (потребуется пароль Вашей учетной записи)
после обработки команды система запросит подтверждение на загрузку и установку пакета, нужно будет нажать клавишу “Y” на клавиатуре, затем нажать Enter
После того, как установка модуля HAL будет завершена необходимо поочередно выполнить следующие команды:

cd ~/.adobe/Flash_Player
rm -rf NativeCache AssetCache APSPrivateData2
К сожалению, в некоторых последних версиях OS Linux модуль HAL полностью удален без возможности установки."
и это все притом что реальни там EME Widewine и Flesh не нужон вообще (у меня его, например, нету и ничего).

Rumpelstilzchen

"Ubuntu 18.10 will have support for fingerprint scanner. This means if your computer has a fingerprint scanner, you would be able to unlock your Ubuntu system with fingerprint."

А мне казалось что fpring можно прикрутить к PAM было уже давным давно.
Но кааанеш забавно как мобильные примочки (все таки именно на мобилках сканеры отпечатков получили распространение, на остальныъ платформах это было но как эзотерика) потихоньку ползут на пекарни.

Rumpelstilzchen

Обновило Убунту до 18,04 и попало....
В 18.04 стоит nvidia-driver-390 (390.48) в котором (еще в 390.25) должен был быть уже пофикшен вот этот баг "Fixed a regression introduced in 390.12 that prevented displays from working normally when running multiple X screens with emulated overlays."

А ХРЕН ТАМ.

То есть в режиме TwinView (два монитора - один рабочий стол, это и есть emulated overlay) случается полная тыква - 640х480 на обоих мониторах с одинаковой картинкой.

Хорошо что у меня есть резервная установка на другом диске, но с тем же хомяком - можно жить пока не пофиксится. Либо откатывать драйвер в 18.04 через add-apt-repository ppa:graphics-drivers/ppa

Rumpelstilzchen

Кажись наконец-то F2FS в GRUB принимают. https://lists.gnu.org/archi...018-04/msg00002.html
HOLY SHIT они там быстрые. Причем патч по сути все тот же, что закинул сам аффтар F2FS еще год тому назад...

Rumpelstilzchen

"I'm afraid nothing has changed in terms of our plans for Linux Galaxy client. It's not being worked on currently and there is no time estimate for when we're gonna take care of it. But yes, it will be done eventually." :-E

Rumpelstilzchen

Такой вопрос, поцоны, есть игора под ляликс и она даже работает, но, охохо, звука нету нихрена.
Судя по тому что она гадит в лог при запуске - звук она пытается выводить в JACK (!), которого у меня нету нихрена, а есть ПшшшАудио (Pulse).
Теперь вопрос, в связи с тем что варианты вовода звука никак в игоре не настраиваются, возможно ли как-то заставить это все работать БЕЗ установки сервера JACK? Например OSS же Пульса может подхватывать...
Не очень охота ставить ради этого и только ради этого JACK...

Добавить пост

Вы можете выбрать до 10 файлов общим размером не более 10 МБ.
Для форматирования текста используется Markdown.